头像

张小飞

我有一壶酒,足以慰风尘

《Ubuntu16.04 安装 KDE桌面》

 2周前  •   Linux  •     •   43  •   0

简述

最近想看看kde下的文件管理器是怎么实现的,因为发现Qt自带的文件管理器是有性能bug的,而且并没有ui线程上的交互处理,如果改的话,只能去更改Qt源码(但是这样改也太蛋疼了,哪有一言不合就去改Qt源码的)。所以想看看同样是Qt写的kde桌面是不是有这个问题。所以装了一个kde的环境来看看,因为也遇到了一些小问题,而且百度出来的全是csdn的乱七八糟的东西,只能自己总结下了。

更改源

ubuntu自带的源没有找到,我就更新了下源。首先备份源

cd /etc/apt/
sudo cp sources.list sources.list.bak

然后都删掉里边的内容 ,添加

# ubuntu16.04 source
deb http://mirrors.ustc.edu.cn/ubuntu/ xenial main restricted universe multiverse
deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-security main restricted universe multiverse
deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-updates main restricted universe multiverse
deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-proposed main restricted universe multiverse
deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial main restricted universe multiverse
deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-security main restricted universe multiverse
deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-updates main restricted universe multiverse
deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-proposed main restricted universe multiverse
deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-backports main restricted universe multiverse

然后再更新源

sudo apt-get update

安装

我的ubuntu环境是16.04所以就按照这个来讲了。

sudo apt-get install kubuntu-desktop

我这里下载了大概1.5G的安装包,然后发现报错,让sudo apt-get -f install 下发现还是报错

// 第一个错误
 kde-telepathy-minimal : 依赖: kde-config-telepathy-accounts (>= 15.04.0) 但是它将不会被安装

// -f install 之后还是报错。
dpkg: 处理归档 /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb (--unpack)时出错:
 正试图覆盖 /usr/share/accounts/services/google-im.service,它同时被包含于软件包 account-plugin-google 0.12+16.04.20160126-0ubuntu1

发现这是Ubuntu的一个bug,把报错的软件包干掉就可以了。

sudo dpkg -r account-plugin-google unity-scope-gdrive

然后再

sudo apt-get -f install 

就ok了。

 

 

上一篇:
下一篇:

 评论


 已有0条评论

    还没有任何评论,你来说两句吧!